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Introduction

The PIV Card Simulator implements 1) the PIV Card Application described in NIST Special Publication 800-73-1, Interfaces for Personal Identity Verification [1] and 2) a platform on which the PIV Card Application runs.  The software comprising the PIV Card Simulator is provided in both source and executable form.  

The PIV Card Simulator is written in C++.  The source code form is provided as a Microsoft Visual Studio .NET project.  The PIV Card Simulator platform supports the loading and selection of applets written in C, C++ and the Java Card variant of the Java programming language.

Architecture

The overall architecture of the PIV Card Simulator is given in Figure 1.
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Figure 1: Architecture of the PIV Reference Implementation

The Card Manager implements the GlobalPlatform [2] LOAD and INSTALL commands without cryptography for loading and installing additional applications on the PIV Card Simulator platform. Support for the Java CardTM runtime environment is provided by the cref program in the Java CardTM 2.2.1 Development Kit [3].

PIV Card Simulator Configuration

The PIV Card Simulator source code includes a set of default data elements that can be reconfigured with a custom data set using the following steps:
1. Generate the data elements that the PIV Card Simulator will be reconfigured with.  Note:  NIST developed the JPIV Data Generation tool that can be used to generate PIV conformant data elements.
2. Extract the PIV Card Simulator source to a directory (e.g., \\PIV Card Simulator\source).

3. Open the \\PIV Card Simulator\source\RefImp\File_Manager\File_System_Initial_Configuration.inc file in a text editor.  This file contains the data element variables and will be edited with new values.
4. Launch the XVI32 hex editor.

5. In XVI32, select File->Open.

6. Browse to a file that contains a data element to load and open it.  Table 1 provides the correlation between data element filenames associated with the JPIV Data Generation tool and data element variables contained in the PIV Card Simulator source code.
7. Click on the first byte in the file and select Edit->Block mark.

8. Click on the last byte in the file and select Edit->Block mark.  All of the bytes in the file should change to red to indicate they have been selected.

9. Select Edit->Clipboard->Copy as hex string.

10. Open a text editor and paste the contents of the clipboard to it.
11. Insert “0x” before the first character in the hex string.

12. Replace all occurrences of blank spaces in the hex string with “,0x”.  An example final string appears below:

0x01,0x20,0x31,0x32,0x33,0x34,0x35,0x36,0x37,0x38,

0x39,0x30,0x31,0x32,0x33,0x34,0x35,0x36,0x37,0x38,

0x39,0x30,0x31,0x20,0x2D,0x20,0x50,0x49,0x56,0x20,

0x54,0x65,0x73,0x74,0x02,0x14,0x31,0x32,0x33,0x34,

0x35,0x36,0x37,0x38,0x39,0x30,0x31,0x32,0x33,0x34,

0x35,0x36,0x37,0x38,0x39,0x30,0x03,0x14,0x31,0x32,

0x33,0x34,0x35,0x36,0x37,0x38,0x39,0x30,0x31,0x32,

0x33,0x34,0x35,0x36,0x37,0x38,0x39,0x30,0x04,0x09,

0x32,0x30,0x30,0x38,0x41,0x55,0x47,0x32,0x34,0x05,

0x0A,0x31,0x32,0x33,0x34,0x35,0x36,0x37,0x38,0x39,

0x30,0x06,0x0F,0x31,0x32,0x33,0x34,0x35,0x36,0x37,

0x38,0x39,0x30,0x31,0x32,0x33,0x34,0x35,0xFE,0x00

13. Select the entire edited hex string and copy it to the clipboard.

14. Replace the value of the corresponding data element variable in the \\PIV Card Simulator\source\RefImp\File_Manager\File_System_Initial_Configuration.inc file with the contents of the clipboard.  Refer to Table 1 for the correct data element variable to overwrite.

15. Repeat steps 5 – 14 for all other data elements that will be configured.

16. Save the changes to the File_System_Initial_Configuration.inc file.

17. Recompile and build the PIV Card Simulator using the instructions provided in the next section.

Table 1.  Data Element Variables in PIV Card Simulator

	Data Element Variable Name
	JPIV Data Element Filename
	Description

	CARD_X509_DATA
	X509_CERTIFICATE_CARD_
AUTHENTICATION
	X.509 Certificate for Card Authentication

	CCC_DATA
	CARD_CAPABILITY_CONTAINER
	Card Capability Container

	CHUID_DATA
	CHUID
	Card Holder Unique Identifier

	FACIAL_IMAGE_DATA
	CARD_HOLDER_FACIAL_IMAGE
	Card Holder Facial Image

	FINGER_1_DATA
	CARD_HOLDER_FINGERPRINTS
	Card Holder Fingerprint I

	FINGER_2_DATA
	n/a
	Card Holder Fingerprint II

	KEY_MANAGEMENT_X509_DATA
	X509_CERTIFICATE_KEY_
MANAGEMENT
	X.509 Certificate for PIV Key Management

	PIV_X509_DATA
	X509_CERTIFICATE_PIV_
AUTHENTICATION
	X.509 Certificate for PIV Authentication

	PRINTED_INFO_DATA
	PRINTED_INFORMATION
	Printed Information

	SECURITY_OBJECT_DATA
	SECURITY_OBJECT
	Security Object

	SIGNING_X509_DATA
	X509_CERTIFICATE_DIGITAL_
SIGNATURE
	X.509 Certificate for PIV Digital Signature


Recompile and Building

To recompile and build the PIV Card Simulator, proceed as follows:

1. Install Microsoft Visual Studio .NET.

2. Verify PIV Card Simulator source (\\PIV Card Simulator\source directory) is extracted and stored on the hard disk.

3. Set the PIV_HOME environment variable to the source directory of the PIV Card Simulator tree.

4. Download the crypto++ package from http://www.eskimo.com/~weidai/cryptlib.html and extract the zip file into %PIV_HOME%\cryptopp\
5. Using one of the methods listed on this page, compile the cryptlib libraries and copy the resulting files to %PIV_HOME%\lib\
6. Open %PIV_HOME%\PIVRefImp\PIV.sln in Visual Studio .NET.

7. Rebuild the solution.

The PIV Card Simulator Executable

The executable program of the PIV Card Simulator is called pivd.exe.  This executable program is placed in the %PIV_HOME%\bin directory by the building process.

The PIV Card Simulator executable, pivd.exe, is a server (just like a real smart card).  pivd listens for application protocol data unit (“APDU”) requests on an Internet port and returns responses to these requests.  pivd uses the TLP-224 communication protocol to receive command APDUs and return response APDUs.

pivd is a DOS command line program that is run in a Windows DOS window.  pivd supports the following command line program options:

usage: pivd [options]

  options:

   -h    --help           print this message

   -v    --verbose        turn on debugging output; 

                          use repeatedly for increasing chattiness

   -p p  --port           listen for connections on port (default=9025)

   -s n  --size           make initial persistent storage n octets

                          (default=32768, ignore if persistent 

                          file read in)

   -i f  --input          read persistent storage from file f 

                          (default is to initialize persistent storage)

   -o f  --output         write persistent storage to file f 

                          (default is to not write persistent

                          storage)

Debug versions of the pivd executable and the DLLs discussed below are distinguished by an uppercase D appended to the file name, so that for instance the Debug version of pivd.exe is pivdD.exe.  The pivdD executable will build to the %PIV_HOME%\bin directory.  This directory also contains the test executable for use with pivdD executable.

The PIV daemon, pivd, executes Java Card applets by running them in the Java Card reference implementation program, cref, that is provided in the Java Card Development Kit.  It does this by executing cref and establishing a TLP-224 link to it on port 9026 of the network node localhost.  One way of defining this network node is to make the following entry in the Hosts file in the c:\windows\system32\drivers\etc directory of Windows:

127.0.0.1       localhost

Details for the preparation and use of the persistent storage file are also given below.

PIV Card Simulator Software Modules

pivd makes use of the following libraries, all of which are created during the build process.

PIV Card Simulator Architecture

· Application – the generic platform application

· Manager – the generic platform runtime environment manager

· Card_Manager – GlobalPlatform LOAD and INSTALL command handler

· File_Manager – Manager of the ISO/IEC 7816 runtime environment

· Java_Card_Manager – the manager of the Java Card runtime environment including loading and instantiation of Java Card applets

ISO/IEC 7816 Runtime Environment

· File_System_Application –  native code application supporting ISO/IEC 7816-4 file system commands

· File_System – ISO/IEC 7816-4 file and data object store

· PCA – the PIV Card Application

Storage Management for the ISO/IEC 7816-4 Runtime Environment

· Octet_String – operations on octet arrays

· Security_System – security condition evaluation and interface to cryptography

· Storage – persistent storage and object management

· TLV  –  operations on TLVs

Communications

· APDU_Packet – encapsulation of the APDUs transported by the TLP224 layer

· APDU_Client – the superclass of the Managers and TLP_APDU_Client, abstracting the service of APDU_exchange

· SocketIO – wrapper for the network socket I/O stack, such as WS2_32, the Microsoft WinSock implementation of Berkeley sockets

· TLP_APDU_Server – the partner to TLP_APDU_Client

· TLP224 – interface to socket level I/O and encapsulating TLP224 packet encoding and decoding

· TLPCLIB – PC/SC interface to TLP-224

In the load-and-go form, pivd uses the dynamically linked Crypto++ library, cryptopp.dll, for its cryptography.  Note that this library is not distributed with the PIV Reference Implementation, so you will need to download and compile it yourself.
Creating, Saving and Restoring the PIV Card Simulator
If pivd is placed in execution without an input configuration file, the only application on the card is the Card Manager.  LOAD and INSTALL commands are sent to the Card Manager to load other applications onto the card.  The Card Manager commands given below load the PIV Card Application (PCA) onto the PIV Card Simulator platform and also serve as an example of how one performs this task using the apdutool program found in the Java Card distribution:

powerup;

// INSTALL for Load APDU - Load the PIV Card Application (PCA)

0x80 0xE6 0x02 0x00 0x17 0x0B 0xA0 0x00 0x00 0x03 0x08 0x00 0x00 0x10 0x00 0x01 0x00 0x04 0xDE 0xAD 0xBE 0xEF 0x00 0x00 0x00 0x02 0x04 0x04 0x7F;

// LOAD Start and End - DLL Name ("PCA")

0x80 0xE8 0x80 0x01 0x05 0xC4 0x03 0x50 0x43 0x41 0x7F;

// INSTALL for Install and Make Selectable APDU - PIV Card Application

0x80 0xE6 0xC0 0x00 0x2A 0x0B 0xA0 0x00 0x00 0x03 0x08 0x00 0x00 0x10 0x00 0x01 0x00 0x0B 0xA0 0x00 0x00 0x03 0x08 0x00 0x00 0x10 0x00 0x01 0x00 0x0B 0xA0 0x00 0x00 0x03 0x08 0x00 0x00 0x10 0x00 0x01 0x00 0x01 0x00 0x02 0x00 0x00 0x00 0x7F;

// Select the PIV Card Application

0x00 0xA4 0x04 0x00 0x0B 0xA0 0x00 0x00 0x03 0x08 0x00 0x00 0x10 0x00 0x01 0x00 0x7F;

After one or more native applications have been loaded onto the PIV Card Simulator platform and interactions with them have possibly changed their data content, one can save the configured card so that interaction can continue with the configured card at a later point in time.  This is accomplished by initiating execution of pivd with the output command line parameter:

pivd –o pivcard.cnf

When the powerdown command is sent to the card the current configuration is written to the file given in this parameter. Interaction with the configuration can be continued at a later point in time by providing this file name to the input command line parameter:

pivd –i pivcard.cnf

In this case you don’t have to load the PIV Card Application because it is already part of the configuration.  You just have to select it to interact with it.

powerup;

// Select the PIV Card Application

0x00 0xA4 0x04 0x00 0x07 0xA0 0x00 0x00 0x01 0xFF 0x01 0x00 0x7F; 

If you want to load a configuration and save changes to it then both the input and output parameters are used:

pivd –i pivcard.cnf –o pivcard.cnf

In this example, an existing PIV card configuration is loaded at powerup and an updated PIV card configuration is saved at powerdown.

There are situations in which you want to have multiple interactions with a PIV Card Simulator configuration over time and there are situations where you want the PIV Card Simulator to act more like a real card and accumulate the interactions with it.
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Figure 2. Saving and Restoring a PIV Card Application Configuration

Creating, Saving and Restoring Java Card Applications

The creating, saving and restoring process is somewhat more complicated if the configuration includes Java Card applets.  This is because the PIV Card Simulator loads and executes Java Card applets in the cref program and cref saves its configuration in its own file.

The creation of a PIV Card Simulator that includes Java Card applets begins with using the compile, convert and scriptgen utilities provided in the Java Card Developer’s Kit to create a script (“SCR”) file with on-card installer (“OCI”) commands.  These commands can load the byte codes of the applet into a Java Card runtime environment, in particular the cref program. The OCI commands in the SCR are then embedded in GlobalPlatform LOAD and INSTALL commands in order to be sent to the Card Manager.

Once this file of GlobalPlatform commands has been prepared, one starts the cref on port 9026 (-p) with the output file option (-o) and pivd with its output file option (-o).

Next one runs the apdutool utility provided in the Java Card Developer’s Kit with the input file to this program being the script file with the GlobalPlatform LOAD and INSTALL commands containing the loadable, byte code version of the application.

The script file loads the Java Card applet into cref.  The fact that this application has been loaded into the Java Card runtime environment is recorded in the Card Manager registry.  The powerdown script command causes pivd to send a powerdown to the cref.  As the cref terminates, it will write its configuration to its output file and as pivd terminates, it will write its configuration to its output file.

Theses two configuration files comprise the saved configuration for a PIV Card Simulator Platform containing Java Card applets. This two-part configuration can be reloaded into pivd and cref at a later point in time in order to continue interaction with it.  

Figure 3 is a diagram of running the PIV Card Simulator with Java Card applets.
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Figure 3: PIV Card Simulator Runtime Configuration with Java Card Applets

Adding a New Native Code Application

The PIV Card Application is a native code application on the PIV Card Simulator platform and it can serve as a model of how to build additional native code applications for the platform.

Possession of the source code of the PIV Card Simulator is necessary in order to write a new native code application but it is not necessary in order to use a native code application.  The LOAD and INSTALL commands given above for the PIV Card Application can be modified to load any native code application rendered as a DLL into the PIV Card Simulator platform.
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